incident.io

We’re seeing issues with dropdowns in Slack
Resolved·Degraded performance

Slack have confirmed on their status page that the issue has been resolved, and we have verified that Slack forms are working again in our own workspace.

If you are still encountering issues, please reload Slack using Command + Shift + R (Mac) or Ctrl + Shift + R (Windows/Linux).

We'll keep monitoring for any further issues, but we're now marking this incident as resolved. 

Thu, Aug 28, 2025, 03:29 PM
(2 weeks ago)
·
Affected components
Slack app
Updates

Resolved

Slack have confirmed on their status page that the issue has been resolved, and we have verified that Slack forms are working again in our own workspace.

If you are still encountering issues, please reload Slack using Command + Shift + R (Mac) or Ctrl + Shift + R (Windows/Linux).

We'll keep monitoring for any further issues, but we're now marking this incident as resolved. 

Thu, Aug 28, 2025, 03:29 PM

Investigating

Some users are running into errors when selecting certain dropdown options in Slack forms. This is tied to an ongoing incident on Slack’s side, which they’re currently investigating. You can follow their updates here: Slack status page.

Our web dashboard isn’t affected and is working as normal. If you hit problems in Slack, you can use the dashboard to complete any actions in the meantime.

We’re keeping an eye on the situation and will share updates as soon as we have them. Thanks for bearing with us.

Thu, Aug 28, 2025, 03:06 PM(22 minutes earlier)