incident.io

Increased latency from the Slack API
Resolved
Degraded performance

We have now consistently seen recovery in the latency when interacting with Slack.

Users will be able to interact with our Slack app as normal, but we'll continue to monitor the situation throughout the day.

Wed, Sep 18, 2024, 10:10 AM
1 week ago
Affected components
Slack app
Updates

Resolved

We have now consistently seen recovery in the latency when interacting with Slack.

Users will be able to interact with our Slack app as normal, but we'll continue to monitor the situation throughout the day.

Wed, Sep 18, 2024, 10:10 AM
32m earlier...

Monitoring

We've seen two periods of latency from the Slack API so far, from 07:54 UTC to 08:14 UTC, and from 09:00 UTC to 09:18 UTC. We are not currently seeing increased latency, but we are monitoring this closely to see if it happens again.

Wed, Sep 18, 2024, 09:38 AM
26m earlier...

Investigating

We are investigating high latency levels when communicating with Slack. Users may see that channel creation is slow, or that messages and DMs from incident.io are slow to show up. We are monitoring this closely and will provide updates as we have them.

Wed, Sep 18, 2024, 09:11 AM