Between 19:31:30 and 19:34:30 UTC, some requests to our dashboard hit increased latency and connectivity errors. The cause was an upstream networking incident on Google Cloud Platform. Errors were transient and refreshing usually cleared them.
Latency and error rates are back to normal and we're keeping an eye on things. We'll post a post-mortem covering the full impact.
Resolved
Between 19:31:30 and 19:34:30 UTC, some requests to our dashboard hit increased latency and connectivity errors. The cause was an upstream networking incident on Google Cloud Platform. Errors were transient and refreshing usually cleared them.
Latency and error rates are back to normal and we're keeping an eye on things. We'll post a post-mortem covering the full impact.
Monitoring
Latency and error rates have returned to normal. We're continuing to monitor for any further issues.
Investigating
We have identified increased latency and timeouts affecting some requests to our dashboard. Issues seem to be transient, and we recommend refreshing.
We are continuing to investigate.