incident.io

Dashboard is slow to load in some regions
Resolved
Partial outage
Lasted for 1d

Following the mitigation that we deployed, our monitoring and testing has shown that we're back to full performance across the globe.

We don't expect to see any further issues.

Thu, Jul 27, 2023, 04:34 PM
9 months ago
Affected components
Dashboard
Updates

Resolved

Following the mitigation that we deployed, our monitoring and testing has shown that we're back to full performance across the globe.

We don't expect to see any further issues.

Thu, Jul 27, 2023, 04:34 PM
3h earlier...

Monitoring

A change to how the dashboard is served to browsers has been implemented, which should mitigate this issue for any affected users. We are continuing to monitor the incident.

Thu, Jul 27, 2023, 01:25 PM
16h earlier...

Identified

There are still issues with the page load time of the dashboard, when accessing from some regions/internet providers.

We're continuing to monitor the situation.

Wed, Jul 26, 2023, 09:14 PM
5h earlier...

Investigating

We've received reports of our dashboard taking a long time to load. We believe that this may be specific to US regions, and could be related to an issue with our infrastructure provider.

We've escalated to the infrastructure provider and investigating options for resolution.

Wed, Jul 26, 2023, 03:42 PM