incident.io

The incident.io bot is being a little too chatty in incidents
Resolved
Degraded performance
Lasted for 53m

A recent optimisation to the code that supports nudges meant it was working much faster, and we were sending messages more frequently than before. We've tweaked things to make us a little less noisy!

Thu, Oct 7, 2021, 10:49 AM
2 years ago
Affected components
Slack app
Updates

Resolved

A recent optimisation to the code that supports nudges meant it was working much faster, and we were sending messages more frequently than before. We've tweaked things to make us a little less noisy!

Thu, Oct 7, 2021, 10:49 AM
27m earlier...

Monitoring

We think the fix that we've applied should solve the problem, we'll continue to monitor in case there's anything that we've missed

Thu, Oct 7, 2021, 10:21 AM

Investigating

We've deployed a change to make the 'update summary' nudge less chatty, which we think is the primary cause of the issue. We're still investigating in case there's anything else going on here. We'll update again in the next half an hour.

Thu, Oct 7, 2021, 10:14 AM
17m earlier...

Investigating

We've notice our bot is being a little bit too chatty in incident channels. We're looking into this now.

Thu, Oct 7, 2021, 09:56 AM