incident.io

Slack operations may fail due to errors from their API
Resolved·Partial outage

We are no longer seeing Slack API errors and have no reason to believe this will reoccur.

As a reminder, whenever Slack has an issue like this our web dashboard, mobile app, and all other incident.io services will continue to work. So if there is ever a Slack issue, jump into the web dashboard to run incident response actions from there, if needed.

We'll be reaching out to Slack to understand what happened.

Thank you for your patience.

Wed, Aug 28, 2024, 06:52 PM
(10 months ago)
·
Affected components
Slack app
Updates

Resolved

We are no longer seeing Slack API errors and have no reason to believe this will reoccur.

As a reminder, whenever Slack has an issue like this our web dashboard, mobile app, and all other incident.io services will continue to work. So if there is ever a Slack issue, jump into the web dashboard to run incident response actions from there, if needed.

We'll be reaching out to Slack to understand what happened.

Thank you for your patience.

Wed, Aug 28, 2024, 06:52 PM

Monitoring

Our monitoring shows Slack API disruption started at 18:14 UTC and recovered by 18:23 UTC. During this time we saw error rates from our Slack clients average at 10% and peak briefly at 40%.

We haven't seen any errors since 18:23 UTC and expect this issue is now resolved. We'll continue to monitor the situation and will resolve this incident if Slack continues to be stable.

We'll be reaching out to Slack's team to understand wha caused this issue.

Wed, Aug 28, 2024, 06:36 PM(15 minutes earlier)

Investigating

We're seeing an elevated rate of errors returned from the Slack API.

This means that actions taken within Slack may fail and incident Slack channels may be slow to create. Retrying is likely to fix the issue, as the connection errors appear temporary.

Alternatively, our web dashboard is unaffected by Slack and can be used to perform incident operations if needed.

Wed, Aug 28, 2024, 06:22 PM(14 minutes earlier)