incident.io

Intermittent Failures with our PagerDuty Integration
Resolved
Partial outage

PagerDuty have confirmed that they disabled API keys which were generated by users that have since been deleted. They have deployed a fix and we are now seeing error rates return to normal levels.

We believe the primary impact is now over, and PagerDuty have marked their service as recovered.

Fri, Jan 24, 2025, 05:07 PM
1 month ago
Affected components
Updates

Resolved

PagerDuty have confirmed that they disabled API keys which were generated by users that have since been deleted. They have deployed a fix and we are now seeing error rates return to normal levels.

We believe the primary impact is now over, and PagerDuty have marked their service as recovered.

Fri, Jan 24, 2025, 05:07 PM
15m earlier...

Identified

PagerDuty's status page has now been updated to reflect issues with their API keys. You can follow along here:

https://status.pagerduty.com/posts/dashboard

Until resolved, please expect further disruption. Our support team and customer success team remain available for those affected in the meantime. More specific updates on impact on an individual customer basis to come very shortly.

Fri, Jan 24, 2025, 04:51 PM
13m earlier...

Identified

We have identified an issue with our PagerDuty integration and are seeing elevated error rates for a subset of customers.

For those affected, this will impact PagerDuty specific workflows, causing a subset of them to fail, as well as introducing noticeable latency increase for functionality like automated escalations via PagerDuty.

We are currently establishing which customers are affected and will update with more information shortly as we learn more.

Fri, Jan 24, 2025, 04:38 PM