incident.io

Issues declaring retrospective incidents
Resolved

This is now resolved, we've been monitoring this and retrospective incident declaration has been back to normal since 10:36.

Fri, Mar 14, 2025, 04:06 PM
2 weeks ago
Affected components

No components marked as affected

Updates

Resolved

This is now resolved, we've been monitoring this and retrospective incident declaration has been back to normal since 10:36.

Fri, Mar 14, 2025, 04:06 PM
5h earlier...

Monitoring

We've rolled back a change and retrospective incident declaration should now be working again.

Fri, Mar 14, 2025, 10:36 AM
35m earlier...

Investigating

We're aware of a problem with declaring retrospective incidents through our web dashboard. We've identified the problem, are working on a fix, and will provide an update as soon as possible.

Fri, Mar 14, 2025, 10:00 AM