incident.io

Issues with the Slack platform
Resolved·Degraded performance

We've seen full recovery across all surfaces, and Slack have closed out their status page incident.

There may be a small delay as we're processing the backlog of delayed events from Slack, but that should clear shortly.

Tue, May 13, 2025, 12:10 AM
(1 month ago)
·
Affected components
Slack app
Updates

Resolved

We've seen full recovery across all surfaces, and Slack have closed out their status page incident.

There may be a small delay as we're processing the backlog of delayed events from Slack, but that should clear shortly.

Tue, May 13, 2025, 12:10 AM

Monitoring

We're starting to see recovery in some areas, with Slack having reported they're rolling out a fix over the next 20 minutes.

We're continuing to monitor the platform's performance.

Mon, May 12, 2025, 11:40 PM(29 minutes earlier)

Investigating

We're seeing an increased delay in some incoming events from Slack, and occasional API failures. We're actively monitoring the situation.

You can follow updates from Slack on their status page: https://slack-status.com/2025-05/7b32241eb41a54aa

Mon, May 12, 2025, 11:18 PM(21 minutes earlier)