incident.io

Insights dashboard experiencing issues
Resolved·Degraded performance

The issue affecting Insights dashboards resolved at 11:27 PM UTC last night, when our external provider's service recovered.

We recognize the significant disruption this caused and take this very seriously. In addition to working closely with our providers, we will be conducting a thorough review of our setup to reduce the risk of similar incidents in the future.

Thank you for your patience and understanding. If you experience any further issues, please contact our support team.

Wed, Jun 11, 2025, 06:34 AM
(1 week ago)
·
Affected components
Insights
Updates

Resolved

The issue affecting Insights dashboards resolved at 11:27 PM UTC last night, when our external provider's service recovered.

We recognize the significant disruption this caused and take this very seriously. In addition to working closely with our providers, we will be conducting a thorough review of our setup to reduce the risk of similar incidents in the future.

Thank you for your patience and understanding. If you experience any further issues, please contact our support team.

Wed, Jun 11, 2025, 06:34 AM

Identified

Insights dashboards remain unavailable due to an ongoing outage with a downstream provider. Their engineering teams are actively working on a fix, but there is still no confirmed timeline for full resolution. We will continue to monitor the situation closely and provide further updates as soon as we have more information.

Thank you for your patience and understanding

Tue, Jun 10, 2025, 08:19 PM(10 hours earlier)

Identified

Insights dashboards remain unavailable due to an ongoing outage with a downstream provider. Their engineering teams are actively working on a fix, but we do not currently have visibility on a resolution timeframe. We will continue to monitor the situation and provide further updates when we know more.

Thanks again for your patience!

Tue, Jun 10, 2025, 05:16 PM(3 hours earlier)

Identified

We're still monitoring this issue closely. We haven't had any significant updates from the downstream providers, and Insights dashboards remain impacted.
Thank you for your continued patience while we work through this issue, and we will continue to update as we learn more!

Tue, Jun 10, 2025, 02:45 PM(2 hours earlier)

Identified

We're continuing to monitor the situation closely. There are still no significant updates from our downstream providers at this time, and Insights dashboards remain impacted for all customers. We're in contact with our partners and will share further updates as soon as we have more information.

Thank you for your continued patience while we work through this issue.

Tue, Jun 10, 2025, 12:10 PM(2 hours earlier)

Identified

We are continuing to closely monitor the situation affecting Insights.

The issue remains unresolved as we are still waiting on a fix from downstream providers. We will provide further updates as soon as we have more information.

Thank you for your patience while we work with our partners to resolve this.

Tue, Jun 10, 2025, 10:24 AM(1 hour earlier)

Identified

We are currently experiencing an issue with a subset of features of our insights product. The root cause is an issue with a downstream provider, and we'll update as we have more information to share.

Tue, Jun 10, 2025, 08:40 AM(1 hour earlier)