Resolved
Vercel have confirmed the issue is resolved and we haven't seen any errors since our last update.
Monitoring
All status pages are loading as normal, we will continue to monitor.
Vercel have implemented a fix for the issue and are monitoring the situation - https://www.vercel-status.com/incidents/j8c0gzj1nw4q
Identified
We're experiencing intermittent issues due to Vercel cloud failures. This means some status pages are slow to load.
We're continuing to monitor the situation. Vercel have identified the issue - and are implementing a fix, more detail can be found on their status page - https://www.vercel-status.com/incidents/j8c0gzj1nw4q