Resolved
The latency looks to have recovered, and Insights charts are loading normally again. We'll keep monitoring for any updates, but we're now marking this incident as resolved.
Investigating
An issue with the third party provider that we use to power Insights is causing graphs to be slow to load. We're monitoring this, and will provide updates when we have them.