incident.io

Slack integration degraded performance
Resolved·Degraded performance

Slack have confirmed on their status page that the issue has been resolved, and we have confirmed that Slack errors and latency are back to expected levels.

If you are still encountering issues, please reload Slack using Command + Shift + R (Mac) or Ctrl + Shift + R (Windows/Linux).

We'll keep monitoring for any further issues, but we're now marking this incident as resolved. 

Fri, Nov 7, 2025, 07:25 AM
(9 hours ago)
·
Affected components
Slack app
Updates

Resolved

Slack have confirmed on their status page that the issue has been resolved, and we have confirmed that Slack errors and latency are back to expected levels.

If you are still encountering issues, please reload Slack using Command + Shift + R (Mac) or Ctrl + Shift + R (Windows/Linux).

We'll keep monitoring for any further issues, but we're now marking this incident as resolved. 

Fri, Nov 7, 2025, 07:25 AM

Identified

We’re monitoring an ongoing incident affecting Slack. The impact appears to be mostly resolved, but we’ll continue to monitor until it’s fully stable. You can follow their updates here.

Fri, Nov 7, 2025, 03:10 AM(4 hours earlier)

Identified

We have identified increased error rates with our slack integration.

We believe latency and error rates have returned to normal and are monitoring any further changes.

We will update with more information shortly as we learn more

Fri, Nov 7, 2025, 02:24 AM(45 minutes earlier)